Resolved
It looks like our authentication provider has resolved their downtime, and the Kombo Dashboard is available again. Thank you for your patience.
Investigating
One of our third-party providers, Frontegg, who we use for authentication on the Kombo Dashboard is currently experiencing a downtime (see https://status.frontegg.com/), which is causing authentication failures/long loading times for customers across both EU and US regions.
The Kombo API is NOT affected by this.
We're in contact with the vendor and exploring possible temporary mitigations. We will update the status page once we know more.