The incident has been resolved. It was triggered by an Ashby rollout that caused unexpected application updates and overloaded our EU infrastructure.
We have disabled this cascading behavior and added safeguards to prevent recurrence. We apologize for any inconvenience.
Resolved
The incident has been resolved. It was triggered by an Ashby rollout that caused unexpected application updates and overloaded our EU infrastructure.
We have disabled this cascading behavior and added safeguards to prevent recurrence. We apologize for any inconvenience.
Monitoring
We've successfully rolled out a mitigation and are observing much improved latencies across affected endpoints. We're continuing to monitor the situation and will provide a postmortem once we've wrapped our internal post-incident workflows.
Monitoring
We have merged a possible mitigation and are monitoring its rollout.
Identified
We have identified the likely root cause of the incident and are working on a mitigation. Latency remains elevated on EU endpoints, particularly for ATS API surface.
Investigating
We are observing elevated response times across our public API and Dashboard/Connect applications on our EU region. US is not affected. We're investigating the cause and possible mitigations.