Resolved
Issue resolved, dashboard operation returned to normal.
Monitoring
Login is working again, there may be some residual slow page loads, we are continuing to monitor the situation.
Monitoring
Users already logged in should be able to use the dashboard, but opening new tabs will take longer. We identified a 3rd party provider as the cause of the degradation, we are monitoring the situation. The Kombo Public API and Kombo Connect are not affected.